Errore di deploy sull’emulatore Windows Phone 8 con codice 0x80131500 ma è colpa di Hyper-V !

Da poco ho comprato un portatile nuovo con l’obiettivo di poter passare dallo sviluppo per Windows Phone 7 a Windows Phone 8, tenendo conto di tutte le caratteristiche di cui necessita quest’ultimo dalla virtualizzazione hardware all’attivazione di Hyper-V.

Installo tutto il necessario, da Visual Studio 2012 Update 4 a Windows Phone 8 SDK ed attivo Hyper-V ma sul più bello, al momento del deploy di una banalissima app “vuota” giusto per verificare che tutto funzioni, ecco che … non funziona nulla !!!

L’errore si presenta in fase di deploy e senza alcun tipo di descrizione ma con il codice 0x80131500 !

Inizia il mio girovagare in rete e pare che l’errore sia legato alla versione Windows 8.1 Preview ma io ho una favolosa Windows 8.1 Professional !

Parlando del problema con Clement Giorio, un altro membro del DotNetCampania, mi rendo conto che l’emulatore WP8 non parte ed allora pensiamo di creare una macchina virtuale per capire se è Hyper-V che non sta facendo il suo dovere.

L’esito è che non riesco nemmeno a creare una semplice macchina virtuale in Hyper-V !

Continuando ad approfondire il problema, ecco che si giunge alla sequenza di operazioni che mi permette di risolvere il problema :

  • Disinstallazione Hyper-V
  • Riavvio
  • Esecuzione di : dism.exe /Online /Cleanup-image /Scanhealth
  • Esecuzione di : dism.exe /Online /Cleanup-image /Restorehealth
  • Riavvio
  • Installazione di Hyper-V

Forse grazie a questo blog post, molte persone eviteranno di perdere le stesse ore che ho perso io !

🙂

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s